CVE-2020-36709

MEDIUM CVSS 3.1: 4.8 EPSS 0.64%
Updated Apr 08, 2026
King-Theme
Parameter Value
CVSS 4.8 (MEDIUM)
Affected Versions before 2.9.4
Fixed In 2.9.4
Type CWE-79 (Cross-Site Scripting (XSS))
Vendor King-Theme
Public PoC No

The Page Builder: KingComposer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via via shortcode in versions before 2.9.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Attack Parameters

Attack Vector
Network
Can be exploited remotely
Attack Complexity
Low
Easy to exploit
Privileges Required
High
Admin privileges needed
User Interaction
Required
User action required

Impact Assessment

Confidentiality
Low
Partial data leak
Integrity
Low
Partial data modification
Availability
None
No disruption

CVSS Vector v3.1

Vulnerable Products 1

Configuration From (including) Up to (excluding)
King-Theme Page_Builder_Kingcomposer
cpe:2.3:a:king-theme:page_builder_kingcomposer:*:*:*:*:*:wordpress:*:*
— 2.9.4