CVE-2024-13907

MEDIUM CVSS 3.1: 6.5 EPSS 0.47%
Updated Mar 11, 2025
Boldgrid
Parameter Value
CVSS 6.5 (MEDIUM)
Affected Versions before 1.16.9
Fixed In 1.16.9
Type CWE-918 (Server-Side Request Forgery (SSRF))
Vendor Boldgrid
Public PoC No

The Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.16.8 via the 'download' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

Attack Parameters

Attack Vector
Network
Can be exploited remotely
Attack Complexity
Low
Easy to exploit
Privileges Required
High
Admin privileges needed
User Interaction
None
No user interaction needed

Impact Assessment

Confidentiality
High
Complete data leak
Integrity
High
Complete data modification
Availability
None
No disruption

CVSS Vector v3.1

Vulnerable Products 1

Configuration From (including) Up to (excluding)
Boldgrid Total_Upkeep
cpe:2.3:a:boldgrid:total_upkeep:*:*:*:*:*:wordpress:*:*
— 1.16.9