CVE-2026-102495

HIGH CVSS 3.1: 7.5 EPSS 0.53%
Updated Oct 06, 2026
Apache
Parameter Value
CVSS 7.5 (HIGH)
Affected Versions before 2.3.3
Fixed In 2.3.3
Type CWE-674
Vendor Apache
Public PoC No

Apache XmlSchema doesn't limit how deeply schema imports and includes can be nested, so a malicious schema can make parsing recurse until the stack overflows. This causes a denial of service. Users are recommended to upgrade to version 2.3.3, which fixes this issue.

Attack Parameters

Attack Vector
Network
Can be exploited remotely
Attack Complexity
Low
Easy to exploit
Privileges Required
None
No privileges needed
User Interaction
None
No user interaction needed

Impact Assessment

Confidentiality
None
No data leak
Integrity
None
No data modification
Availability
High
Complete denial of service

CVSS Vector v3.1

Weakness Type (CWE)

Vulnerable Products 1

Configuration From (including) Up to (excluding)
Apache Xmlschema
cpe:2.3:a:apache:xmlschema:*:*:*:*:*:*:*:*
— 2.3.3