CVE-2026-54710

HIGH CVSS 4.0: 8.6 EPSS 0.51%
Updated Oct 16, 2026
Sangoma
Parameter Value
CVSS 8.6 (HIGH)
Affected Versions 16.0 — 17.0.7
Fixed In 16.0.40
Type CWE-20 (Improper Input Validation), CWE-94 (Code Injection)
Vendor Sangoma
Public PoC No

FreePBX is an open source IP PBX. Prior to versions 16.0.40 and 17.0.7, a critical remote code execution (RCE) vulnerability exists in the superfecta module due to unsafe inclusion of arbitrary PHP files, allowing authenticated attackers to execute arbitrary PHP code on the server with the privileges of the web server user. Authentication with a known username is required.

The vulnerability is rooted in the options and save_options cases in the Superfecta module's AJAX handler. The code dynamically includes PHP files from the sources/ directory based on user-supplied input. This allows an attacker to execute arbitrary code when combined with arbitrary directory creation (e.g., via the backup module) and file uploads that reveal full paths (e.g., via the soundlang module).

This issue has been patched in versions 16.0.40 and 17.0.7.

Attack Parameters

Attack Vector
Network
Can be exploited remotely
Attack Complexity
Low
Easy to exploit
Attack Requirements
None
No additional conditions
Privileges Required
Low
Basic privileges needed
User Interaction
None
No user interaction needed

Impact Assessment

Confidentiality
High
Complete data leak
Integrity
High
Complete data modification
Availability
None
No disruption

CVSS Vector v4.0

Vulnerable Products 2

Configuration From (including) Up to (excluding)
Sangoma Freepbx
cpe:2.3:a:sangoma:freepbx:*:*:*:*:*:*:*:*
16.0 16.0.40
Sangoma Freepbx
cpe:2.3:a:sangoma:freepbx:*:*:*:*:*:*:*:*
17.0 17.0.7