CVE-2023-2279

MEDIUM CVSS 3.1: 5.4 EPSS 0.29%
Updated Apr 08, 2026
Wpdirectorykit
Parameter Value
CVSS 5.4 (MEDIUM)
Affected Versions before 1.2.2
Fixed In 1.2.2
Type CWE-352 (Cross-Site Request Forgery (CSRF))
Vendor Wpdirectorykit
Public PoC No

The WP Directory Kit plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.1. This is due to missing or incorrect nonce validation on the 'admin_page_display' function. This makes it possible for unauthenticated attackers to delete or change plugin settings, import demo data, modify or delete Directory Kit related posts and terms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Partial patches were made avilable in versions 1.2.0 and 1.2.1 but the issue was not fully patched until 1.2.2

Attack Parameters

Attack Vector
Network
Can be exploited remotely
Attack Complexity
Low
Easy to exploit
Privileges Required
None
No privileges needed
User Interaction
Required
User action required

Impact Assessment

Confidentiality
None
No data leak
Integrity
Low
Partial data modification
Availability
Low
Partial disruption

CVSS Vector v3.1

Vulnerable Products 1

Configuration From (including) Up to (excluding)
Wpdirectorykit Wp_Directory_Kit
cpe:2.3:a:wpdirectorykit:wp_directory_kit:*:*:*:*:*:wordpress:*:*
— 1.2.2