CVE-2023-2351

MEDIUM CVSS 3.1: 4.3 EPSS 0.64%
Updated Apr 08, 2026
Wpdirectorykit
Parameter Value
CVSS 4.3 (MEDIUM)
Affected Versions before 1.2.4
Fixed In 1.2.4
Type CWE-862 (Missing Authorization)
Vendor Wpdirectorykit
Public PoC No

The WP Directory Kit plugin for WordPress is vulnerable to unauthorized modification of data and loss of data due to a missing capability check on the 'ajax_admin' function in versions up to, and including, 1.2.3. This makes it possible for authenticated attackers with subscriber-level permissions or above to delete or change plugin settings, import demo data, delete Directory Kit related posts and terms, and install arbitrary plugins. A partial patch was introduced in version 1.2.0.

Attack Parameters

Attack Vector
Network
Can be exploited remotely
Attack Complexity
Low
Easy to exploit
Privileges Required
Low
Basic privileges needed
User Interaction
None
No user interaction needed

Impact Assessment

Confidentiality
None
No data leak
Integrity
Low
Partial data modification
Availability
None
No disruption

CVSS Vector v3.1

Vulnerable Products 1

Configuration From (including) Up to (excluding)
Wpdirectorykit Wp_Directory_Kit
cpe:2.3:a:wpdirectorykit:wp_directory_kit:*:*:*:*:*:wordpress:*:*
— 1.2.4