Плагин WP Directory Kit для WordPress уязвим к подделке межсайтовых запросов в версиях до 1.2.1 включительно. Это связано с отсутствием или неправильной проверкой nonce в функции «admin_page_display». Это позволяет неаутентифицированным злоумышленникам удалять или изменять настройки плагина, импортировать демонстрационные данные, изменять или удалять сообщения и условия, связанные с Directory Kit, с помощью поддельного запроса, при условии, что они могут обманом заставить администратора сайта выполнить такое действие, как нажатие на ссылку.
Частичные исправления были доступны в версиях 1.2.0 и 1.2.1, но проблема не была полностью исправлена до версии 1.2.2.
Показать оригинальное описание (EN)
The WP Directory Kit plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.1. This is due to missing or incorrect nonce validation on the 'admin_page_display' function. This makes it possible for unauthenticated attackers to delete or change plugin settings, import demo data, modify or delete Directory Kit related posts and terms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Partial patches were made avilable in versions 1.2.0 and 1.2.1 but the issue was not fully patched until 1.2.2
Характеристики атаки
Последствия
Строка CVSS v3.1
Тип уязвимости (CWE)
Уязвимые продукты 1
| Конфигурация | От (включительно) | До (исключительно) |
|---|---|---|
|
Wpdirectorykit Wp_Directory_Kit
cpe:2.3:a:wpdirectorykit:wp_directory_kit:*:*:*:*:*:wordpress:*:*
|
— |
1.2.2
|